About This Site

Don't see an issue posted here? Contact the ITS Support Center

How do I manage my subscriptions?

Thursday October 15th 2020

Blackboard Blackboard Outage

Update 8:55 AM: Blackboard has implemented a fix and the issue has been resolved.


Update 7:35 AM: The site is starting to come back online but is performing slowly. We will post an update when the system is fully online.


Blackboard is experiencing a major outage and is currently offline. We have notified the vendor and they are working to resolve the outage.