About This Site

Don't see an issue posted here? Contact the ITS Support Center

How do I manage my subscriptions?

Friday January 22nd 2021

Colleague Colleague Emergency Maintenance 12pm-1pm

Update 1:00 PM: The Colleague system is now back online.


Update 12:20 PM: The maintenance window is being extended until 1:00 PM. We will post an update once the system is back online.


The Colleague system will be offline 12pm-12:30pm for emergency maintenance. More info: https://status.forsythtech.edu