About This Site

Don't see an issue posted here? Contact the ITS Support Center

How do I manage my subscriptions?

Monday September 27th 2021

Telephone System Phone System Call Performance Issues

Update 3:00 PM (9/29/2021): We have received an update of intermittent issues being reported that appear to be limited to inbound calls coming from the Verizon Wireless network. While you may still experience these intermittent call issues, the observation is that the trouble is not as widespread as the previous days and has narrowed in scope.


Update 2:00 PM (9/28/2021): We have just been notified by our service provider that they are starting to see sporadic issues with inbound calls resulting in the same issue of audio to drop. At this time, it looks to only impact inbound calls and not outbound. We will post any new information as it is made available to us.


Update 9:25 PM: We have received notice from our service provider that the issues have been resolved. We will continue to monitor the situation


Update: We have identified the issue with the phone system as an outage with our carrier impacting multiple customers in the area. We will post an update once the service issue is resolved.


We are experiencing issues with our phone system that is causing audio to drop on some inbound and outbound external calls.