About This Site

Don't see an issue posted here? Contact the ITS Support Center

How do I manage my subscriptions?

Wednesday December 1st 2021

Blackboard Blackboard Outage

Update 2:04 PM: Blackboard is now back online.


Update 1:41 PM: Blackboard has confirmed the outage is impacting the US EAST COAST Region. There is no ETA for resolution.


Blackboard is currently experiencing an outage. We have notified the vendor and expecting an update soon. We will post an update once the issue is resolved.