About This Site

Don't see an issue posted here? Contact the ITS Support Center

How do I manage my subscriptions?

Friday February 18th 2022

Campus Network Connectivity Network outage impacting all locations

Update 12:55 PM EST: Internet connectivity has been restored to all campus locations. All systems are back online.


Update 11:15 AM EST: Our Internet Service Provider is continuing to work with local utility companies to restore power to their equipment sites. The following systems are currently unavailable: MyForsythTech, OnBase, and Informer.


Update 8:30 AM EST: We are experiencing an internet outage impacting all campus locations. Our Internet Service provider has experienced a local equipment failure and is actively working to restore service. All online services such as Blackboard, Techlink, Email, etc are online and accessible off campus. We will post an update once the issue is resolved.


We are experiencing an internet/phone system outage impacting all campus locations.