About This Site

Don't see an issue posted here? Contact the ITS Support Center

How do I manage my subscriptions?

Thursday April 7th 2022

Campus WiFi WiFi Service Issues All Campuses

Update 1:45 PM EST: All remaining issues with Guest access to the WiFi networks has been resolved.


Update 11:37 AM EST: The WiFi Networks at all campus locations are now functional for all students and employees. Guests without a Forsyth Tech TechID account are currently unable to connect to the WiFi networks due to the SMS text sign in option not functioning reliably. The Vendor is actively working on implementing a solution to fix the SMS text sign in issue.


We are currently experiencing issues with the WiFi networks at all campuses that is preventing new devices from being able to connect. We have identified the cause and are actively working with our vendors on implementing a solution.