About This Site

Don't see an issue posted here? Contact the ITS Support Center

How do I manage my subscriptions?

Thursday September 15th 2022

Campus Network Connectivity Internet Outage Impacting Multiple Campuses

UPDATE 2:50 PM EST: The outage has been resolved.


UPDATE 1:55 PM EST: Our Internet Service Provider has notified us that they are experiencing a widespread outage with no ETA on resolution. The following locations are impacted: Network connectivity at Main Campus, Transportation Center, Mazie Woodruff Center, Grady Swisher Center, & West Campus. The following systems are offline due to this outage: MyForsythTech, VPN, FT Org, EWD CRM, HR Evaluation System, Course Substitution System, Short URL.


We are experiencing internet & phone system outages at multiple campus locations.